انجمن تخصصی رباتیک و الکترونیک

  1. alighaffari3000
  2. آردوینو
  3. یکشنبه, 01 آوریل 2018
  4.  اشتراک از طریق ایمیل
با سلام خدمت دوستان
من یه شیلد شبکه اترنت W5100 از کافه روبوت گرفتم.
واسه راه اندازیش هم همون کابلی که همیشه pc رو به مودم وصل میکنم بهش وصل کردم.
کد زیر رو واسه راه اندازیش روش ریختم :

#include <SPI.h>
#include <Ethernet.h>

// Enter a MAC address for your controller below.
// Newer Ethernet shields have a MAC address printed on a sticker on the shield
byte mac[] = {
0x00, 0xAA, 0xBB, 0xCC, 0xDE, 0x02 };

// Initialize the Ethernet client library
// with the IP address and port of the server
// that you want to connect to (port 80 is default for HTTP):
EthernetClient client;

void setup() {
// start the serial library:
Serial.begin(9600);
// start the Ethernet connection:
if (Ethernet.begin(mac) == 0) {
Serial.println("Failed to configure Ethernet using DHCP");
// no point in carrying on, so do nothing forevermore:
for(;;)
;
}
// print your local IP address:
Serial.print("My IP address: ");
for (byte thisByte = 0; thisByte < 4; thisByte++) {
// print the value of each byte of the IP address:
Serial.print(Ethernet.localIP()[thisByte], DEC);
Serial.print(".");
}
Serial.println();
}

void loop() {

}



کد با موفقیت روی آردوینو ریخته میشه و چراغ های شیلد شبکه هم روشن و خاموش میشن. ولی در عمل اتفاقی نمیوفته! توی سریال مانیتور هیچی نشون داده نمیشه! نه پیغام "Failed to configure Ethernet using DHCP" میاد و نه پیغام موفقیتی دیده میشه! انگار اصلا چیزی به مودم وصل نیست! توی تنظیمات مودم هم رفتم دیدم مودم اینو نشناخته! اصلا انگار چیزی به مودم وصل نیست.
اینم بگم که روی برد، مک ادرس نوشته نشده و من واسه مک ادرس هم اینی که تو کده و هم چند تا ادرس دیگه رو امتحان کردم.
یکی دو تا نمونه کد دیگه رو هم تست کردم ولی بازم نتیجه نمیده :(
مدل مودم d-link 2730u هستش و به خوبی هم کار میکنه. به همون کابل به pc و لپتاپ وصل میکنم مشکلی نداره.
اگه دوستان چیزی به ذهنشون میرسه ممنون میشم راهنمایی کنند


هنوز به این بحث پاسخی داده نشده است.
شما نیز اجازه ارسال پاسخ را ندارید